网管注意 PHP 5.2.5之前版本多个安全漏洞

11/26/2007来源:PHP技巧人气:10508

发布日期:2007-11-08

更新日期:2007-11-13

受影响系统:

php PHP < 5.2.5

不受影响系统:

PHP PHP 5.2.5

描述:

BUGTRAQ ID: 26403

----CVE(CAN) ID: CVE-2007-4887


PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。


PHP的5.2.5之前版本中存在多个安全漏洞,具体包括:


1) htmlentities和htmlspecialchars函数中不会接受部分多字节序列;

2) fnmatch()、setlocale()和glob()函数中存在多个缓冲器溢出;

3) 处理.htaccess文件中的错误可能导致通过.htaccess文件修改mail.force_extra_parameters php.ini指令,绕过disable_functions指令;

4) 处理变量中的错误可能导致通过ini_set()函数覆盖httpd.conf中所设置的值。


目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:http://www.php.net/get/php-5.2.5.tar.bz2/from/a/mirror